We continue to monitor email deliverability for Comcast email addresses. Our email provider is gradually increasing the volume of messages sent through the new dedicated delivery path; while deliverability is improving, some Comcast recipients may still experience delayed or unsuccessful delivery during this transition.
We will continue to share updates as progress is made.
Monitoring
We continue to monitor email deliverability for Comcast email addresses. Our email provider is gradually increasing the volume of messages sent through the new dedicated delivery path; while deliverability is improving, some Comcast recipients may still experience delayed or unsuccessful delivery during this transition.
We will continue to share updates as progress is made.
Monitoring
We continue to monitor email deliverability for Comcast email addresses. Our email provider is gradually increasing the volume of messages sent through the new dedicated delivery path; while deliverability is improving, some Comcast recipients may still experience delayed or unsuccessful delivery during this transition.
We will continue to share updates as progress is made.
Monitoring
We are monitoring an issue that impacts email deliverability for Comcast email addresses. While we have resolved the underlying issue, users with Comcast email addresses might continue to have issues receiving email messages from CivicPlus products. We will provide regular updates over the upcoming weeks and will confirm when there is full resolution.
Identified
We have identified the cause of the issue affecting email delivery and are working on proactive resolution. Users with Comcast email addresses may continue to experience deliverability issues and might start to see resolution in 24 hours, however, it may take several days until everything is fully mitigated through our downstream provider.
We will continue to post updates as they are available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
Our team continues to work on resolving the issue. We will provide the next update within 30 minutes or sooner if additional information becomes available.
Investigating
We are investigating an issue between AWS and Comcast that may prevent delivery of transactional and subscription-related messages affecting recipients with Comcast email addresses, including authentication, verification, alerts, and other product notifications across products. We will provide another update within 30 minutes.