Resolved
This issue has been resolved and services are operating normally. We appreciate your patience while we worked to restore service.
Monitoring
From approximately 8:00 AM EDT to 8:20 AM EDT CivicPlus Payments experienced a performance degradation due to an outage with an upstream provider. A fix has been implemented and services have been restored. We are continuing to monitor system performance to ensure stability. If you continue to experience issues, please contact support.