Resolved
This issue has been resolved and services are operating normally. We appreciate your patience while we worked to restore service.
Identified
We have identified the cause of the issue affecting Payments and are actively working on a resolution. Users may continue to experience transaction failures until mitigation is complete. We will provide another update within 15 minutes.