Resolved
This issue has been resolved and services are operating normally. We appreciate your patience while we worked to restore service.
Investigating
We are currently investigating an issue with an upstream provider affecting CivicPlus Payments EMV devices. Users may experience a performance degradation related to EMV transactions.